Jump to page titleUNITED STATES
hp.com home products and services support and drivers solutions how to buy
» contact hp


more options
 
hp.com home
End of Jump to page title
HP Services software patches
Jump to content


» software & drivers
» ask Compaq
» reference library
» forums & communities
» support tools
» warranty information
» contact support
» parts
» give us feedback

associated links
» what's new
» contract access
» browse patch tree
» search patch tree
» join mailing list

patches by topic
» DOS
» OpenVMS
» Security
» Tru64 Unix
» Ultrix 32
» Windows
» Windows NT

connection tools
» nameserver lookup
» traceroute
» ping


Find Support Information and Customer Communities for Presario.
Content starts here
OpenVMS DCE_030_SSRT3608-V0100 Alpha V6.2 through V7.3-1 ECO Summary
TITLE: OpenVMS DCE_030_SSRT3608-V0100 Alpha V6.2 through V7.3-1 ECO Summary
 
NOTE:  An OpenVMS saveset or PCSI installation file is stored
       on the Internet in a self-expanding compressed file.
 
       For OpenVMS savesets, the name of the compressed saveset
       file will be kit_name.a-dcx_vaxexe for OpenVMS VAX or
       kit_name.a-dcx_axpexe for OpenVMS Alpha. Once the OpenVMS
       saveset is copied to your system, expand the compressed
       saveset by typing RUN kitname.dcx_vaxexe or kitname.dcx_alpexe.
 
       For PCSI files, once the PCSI file is copied to your system,
       rename the PCSI file to kitname.pcsi-dcx_axpexe or
       kitname.pcsi-dcx_vaxexe, then it can be expanded by typing
       RUN kitname.pcsi-dcx_axpexe or kitname.pcsi-dcx_vaxexe.  The
       resultant file will be the PCSI installation file which can be
       used to install the ECO.
 

 


New Kit Date:       11-SEP-2003
Modification Date:  None
Modification Type:  NEW KIT



Copyright (c) Hewlett-Packard Company 2003.  All rights reserved.

OP/SYS:     OpenVMS Alpha

COMPONENT:  SSRT3608

SOURCE:     Hewlett-Packard Company

ECO INFORMATION:

     ECO Kit Name:  DCE_030_SSRT3608-V0100
                    DEC-AXPVMS-DCE_030_SSRT3608-V0100--4.PCSI
     ECO Kits Superseded by This ECO Kit:  None 
     ECO Kit Approximate Size:  28496 Blocks
     Kit Applies To: OpenVMS Alpha V6.2 through V7.3-1
     System/Cluster Reboot Necessary:  No
     Rolling Re-boot Supported:  None
     Installation Rating: INSTALL_2: To be installed by all customers using the
                                     following feature(s):

      -  DCE and/or RPC

     This installation rating, based upon current  CLD  information,  is
     provided  to  serve as a guide to which customers should apply this
     remedial kit.   (Reference  attached  Disclaimer  of  Warranty  and
     Limitation of Liability Statement)


     Kit Dependencies:

     The following remedial kit(s) must be installed BEFORE
     installation of this kit:

       o  V7.2-2 :  DEC-AXPVMS-VMS722_PCSI-V0100--4.PCSI

       o  V7.3 :  DEC-AXPVMS-VMS73_PCSI-V0100--4.PCSI

       o  V7.3-1 :  DEC-AXPVMS-VMS731_PCSI-V0100--4.PCSI

     In order to receive all the corrections listed in this
     kit, the following remedial kits should also be installed:

       o  DEC-AXPVMS-DCOM_013_SSRT3608-V0100--4.PCSI


FILES PATCHED OR REPLACED:


      o  [SYSLIB]DCE$LIB_SHR.EXE (new image for Alpha V7.2 and higher)

         Image Identification Information:

         image name: "DCE$LIB_SHR"
         image file identification: "DCE V3.0-020926"
         image file build identification: ""
         link date/time: 18-AUG-2003 05:40:41.73
         linker identification: "A11-50"

      o  [SYSLIB]DCE$LIB_SHR.EXE (new image for Alpha versions prior to
         V7.2)

         Image Identification Information:
         image name: "DCE$LIB_SHR"
         image file identification: "DCE V3.0-020930"
         image file build identification: ""
         link date/time: 20-AUG-2003 07:06:04.27
         linker identification: "A11-20"



PROBLEMS ADDRESSED IN THIS KIT

New problems addressed in the DCE_030_SSRT3608-V0100 kit

     o  Denial Of Service

        A potential denial of service has been identified on
        OpenVMS systems with DCE or COM installed.  These OpenVMS
        system could be vunerable to a remote initated Buffer
        Overflow which would result a hang of DCE or COM
        applications on OpenVMS.

        In addition to the DCE_030_SSRT3608-V0100 ECO kit,
        OpenVMS customers with DCE or RPC applications in use on
        their systems should apply the recommended
        DCOM_013_SSRT3608-V0100 patch as soon as possible to
        prevent applications hangs.

        Images Affected: [SYSLIB]DCE$LIB_SHR.EXE


INSTALLATION INSTRUCTIONS:

Installation Command

     Install this kit with the POLYCENTER Software installation utility
     by logging into the SYSTEM account, and typing the following at the
     DCL prompt:

     PRODUCT INSTALL DCE_030_SSRT3608 /SOURCE=[location of Kit]

     The kit location may be a tape drive, CD, or a disk directory that
     contains the kit.

     Additional help on installing PCSI kits can be found by typing
     HELP PRODUCT INSTALL at the system prompt



Scripting of Answers to Installation Questions

     During installation, this kit will ask and require user response to
     several questions.  If you wish to automate the installation of
     this kit and avoid having to provide responses to these questions,
     you must create a DCL command procedure that includes the following
     definitions and commands:

      -  $ DEFINE/SYS NO_ASK$BACKUP TRUE

      -  Add the following qualifiers to the PRODUCT INSTALL command and
         add that command to the DCL procedure.

           /PROD=DEC/BASE=AXPVMS/VER=V1.0


      -  De-assign the logicals assigned

For example, a sample command file to install the
DCE_030_SSRT3608-V0100 kit would be:

     $
     $ DEFINE/SYS NO_ASK$BACKUP TRUE
     $!
     $ PROD INSTALL DCE_030_SSRT3608/PROD=DEC/BASE=AXPVMS/VER=V1.0
     $!
     $ DEASSIGN/SYS NO_ASK$BACKUP
     $!
     $ exit



Special Installation Instructions:

     One of the following commands must be run prior to installing  this
     kit:

      o  Fully configured DCE V3.0 systems:

                @SYS$MANAGER:DCE$SETUP CLEAN


      o  RPC only configured systems:

                @SYS$MANAGER:DCE$RPC_SHUTDOWN



     One  of  the  following  commands  must  be  run  after   the   kit
     installation completes:

      o  Fully configured DCE V3.0 systems:

               @SYS$MANAGER:DCE$SETUP START


      o  RPC only configured systems:

               @SYS$MANAGER:DCE$RPC_STARTUP



COPYRIGHT AND DISCLAIMER:

     (C) Copyright 2003 Hewlett-Packard Development Company, L.P.

     Confidential computer software.  Valid license from HP  and/or  its
     subsidiaries required for possession, use, or copying.

     Consistent  with  FAR  12.211  and  12.212,   Commercial   Computer
     Software,  Computer  Software Documentation, and Technical Data for
     Commercial  Items  are  licensed  to  the  U.S.   Government  under
     vendor's standard commercial license.

     Neither HP  nor  any  of  its  subsidiaries  shall  be  liable  for
     technical  or  editorial errors or omissions contained herein.  The
     information in this document is provided "as is"  without  warranty
     of  any  kind  and  is  subject  to  change  without  notice.   The
     warranties for HP products are set forth  in  the  express  limited
     warranty  statements  accompanying  such  products.  Nothing herein
     should be construed as constituting an additional warranty.

     DISCLAIMER OF WARRANTY AND LIMITATION OF LIABILITY

     THIS PATCH IS PROVIDED AS IS, WITHOUT WARRANTY OF  ANY  KIND.   ALL
     EXPRESS  OR  IMPLIED  CONDITIONS,  REPRESENTATIONS  AND WARRANTIES,
     INCLUDING ANY IMPLIED  WARRANTY  OF  MERCHANTABILITY,  FITNESS  FOR
     PARTICULAR PURPOSE, OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED TO THE
     EXTENT PERMITTED BY APPLICABLE LAW.  IN NO  EVENT  WILL  COMPAQ  BE
     LIABLE  FOR  ANY  LOST REVENUE OR PROFIT, OR FOR SPECIAL, INDIRECT,
     CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER  CAUSED  AND
     REGARDLESS  OF  THE  THEORY OF LIABILITY, WITH RESPECT TO ANY PATCH
     MADE AVAILABLE HERE OR TO THE USE OF SUCH PATCH.

Files on this server are as follows:
»dec-axpvms-dce_030_ssrt3608-v0100--4.README
»dec-axpvms-dce_030_ssrt3608-v0100--4.CHKSUM
»dec-axpvms-dce_030_ssrt3608-v0100--4.pcsi-dcx_axpexe
privacy statement using this site means you accept its terms